Antwort schreiben 
 
Themabewertung:
  • 1 Bewertungen - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with item value calculation
25.08.2011, 21:26 (Dieser Beitrag wurde zuletzt bearbeitet: 25.08.2011 21:57 von ant.)
Beitrag #1
Problem with item value calculation
Hi,

I believe there is something wrong with item value calculation. Here are my settings:

[Bild: itemsettings.png]

This is my current shoe:

[Bild: currentshoe.png]

and this is the quest reward:

[Bild: questshoe.png]

Based on the calculation explained in the manual (http://help.sfbot.de/settings/character/...tems.html) I get the following results:

current shoe: 362 armor x 0.1 + 268 con x 2 = 36 + 536 = 572
quest shoe: 395 armor x 0.1 + 162 con x 2 + 110 luck x 1.5 = 39 + 324 + 165 = 528

So the bot should keep the current one and ignore the quest item (572 > 528). However, the bot selects the quest with this shoe, saying "quest reward ... is better than equipped item" - which is WRONG.

Before you ask, here are my quest settings:

[Bild: questsettings.png]

Am I doing something wrong, or is the bot calculating wrong?!



Now it got me a new necklace:

[Bild: questneckl.png]

138 dex x 0 + 126 int x 3 = 378


While this is my current one:

[Bild: currentneckl.png]

280 int x 3 = 840


Help!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
27.08.2011, 14:55
Beitrag #2
RE: Problem with item value calculation
Today I checked a quest with item reward: necklace of ... luck +156, strength +112, and the bot gives an estimate of 361243 s. I tried changing the item settings (originally as show in my previous post, then everything set to 1, etc), but it always gave the same estimate. So it looks like the bot uses some pre-set values and totally ignores the settings. Could you check this?

Thanks
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.08.2011, 10:59
Beitrag #3
RE: Problem with item value calculation
funny - no problems an my xp-notebook....

first i thought the problem may be the value behind the point - 362 x 0.1 = 36.2. but the estimated value you gave is quite funny...i have had same problems before. then, my bot completely crashed. then, i installed the very new version and redid all the accounts. finally it worked.

maybe you are using win7 - changes of values are displayed but not calculated. check your sfbot.ini and retry in admin-mode?

the bot does not work correctly on my win7 - i dunno why. but on my xp-notebook --> no probs at all...all with a copied version of sfbot.ini...?

bitte zuerst lesen: http://help.sfbot.de/
check this first: http://help.sfbot.de/
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.08.2011, 17:59
Beitrag #4
RE: Problem with item value calculation
Well, I tried to change the values in sfbot.ini but it always gives the same estimate in the log. Even if I set everything to 0, the value will be non-zero... Reconfiguring the account didn't work either. Oh, and I'm using win xp too.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste

Kontakt | Shakes & Fidget Bot | Nach oben | Zum Inhalt | Archiv-Modus | RSS-Synchronisation